Deleted Mailboxes are not appeared on the Disconnected Mailboxes on Exchange 2007/2010

I deleted a user mailbox but still his Email coming on the GAL, so I did update the GAL, Address list and the OAB but with no luck, so I decided to restore the Email from the Disconnected mailbox and mark the mailbox properties “Hide from GAL”

But also when going to disconnected mailboxes, the deleted mailbox was not there!!

After searching I found this shell command:

clip_image002

But if you have a cluster, you should put the cluster name before the database name:

clip_image004

Then go to the Disconnected Mailboxes, connect the mailbox, search for the mailbox under recipient configuration:

clip_image006

Check “hide from Exchange Address List”, then Apply.

Updating the GAL requires some time, or do it manually by the command shell:

Get-GlobalAddressList | Update-GlobalAddressList

Get-Addresslist | Update-Addresslist

Get-OfflineAddressBook | Update-OfflineAddressBook

Or update the address list from the outlook by send/receive then choose download the address book.

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: